Notice: The Tweet Nest support forum has been moved to the GitHub issue tracker. Please report all issues there. Thank you!
Post a reply

.htaccess issues ..

A forum thread posted in Tweet Nest by faintdreams on Mar 6th, 2013

faintdreams OP

I’ve been using Tweetnest happily since 2010, and in the past few months I’ve been getting 404 errors when trying to access my archives. New tweets appear to be added fine, but I cannot access any information about them.

i have more than one .htaccess file, and as far as i can tell they are all doing what they should be doing. I’ve copied and pasted the text on each to allow anyone who might be able to help me fix/troubleshoot this issue. I have removed my specific domain name.

My htaccess files are located at
/
/public_html
/public_html/tweetnest
/public_html/tweetnest/maintenance

I am running PHP Version 5.2.17

/.htaccess

Options +FollowSymLinks

ReWriteEngine On
ReWriteBase /
RewriteCond %{THE_REQUEST} ^.*/index.html
RewriteRule ^(.*)index.html$ http://www.mydomainame.com/blog/$1 [R=301,L]
RewriteCond %{THE_REQUEST} ^.*/index.php
RewriteRule ^(.*)index.php$ http://www.mydomainname.com/blog/$1 [R=301,L]

Options +Indexes

/public_html
Empty of all text

/public_html/tweetnest

RewriteEngine On
RewriteRule ^sort/?$ ./sort.php [L]
RewriteRule ^favorites/?$ ./favorites.php [L]
RewriteRule ^search/?$ ./search.php [L]
RewriteRule ^([0-9]+)/([0-9]+)/?$ ./month.php?y=$1&m=$2
RewriteRule ^([0-9]+)/([0-9]+)/([0-9]+)/?$ ./day.php?y=$1&m=$2&d=$3
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]

/public_html/tweetnest/maintenance

RewriteEngine On
RewriteRule ^sort/?$ ./sort.php [L]
RewriteRule ^favorites/?$ ./favorites.php [L]
RewriteRule ^search/?$ ./search.php [L]
RewriteRule ^([0-9]+)/([0-9]+)/?$ ./month.php?y=$1&m=$2
RewriteRule ^([0-9]+)/([0-9]+)/([0-9]+)/?$ ./day.php?y=$1&m=$2&d=$3

Am I missing text from any of the .htaccess files or are there more than there should be?

I have already tried a new setup of Tweetnest using an entirely new database, and I still get the same 404 when trying to access archive tweet info.

I know that tweetnest is provided to be used at users own caution, but I’d really appreciate some help fixing this issue. Up until now I’ve been really happy with it, and would really like to continue using it.

Thanks

Reply

graulund

If nothing has changed in your htaccess files, then it’s hard to believe that they are the cause of the problems you’re experiencing. Did you add some new webapp to your web server lately? Maybe it’s conflicting somehow.

Otherwise, something like this is so closely related to how your specific web server works that it’s really hard for me to debug sitting over here.

In any regard, Tweet Nest 2 is coming out later this month and will have way fewer htaccess files. So that’s something. :)

Reply

faintdreams OP

Thanks for the reply, I appreciate how diff the problem is to troubleshoot. I look forward to Tweet Nest 2.

Reply

bengo35

If this comes from your apache configuration, try:

“sudo nano /etc/apache2/sites-enabled/000-default”

Then, in the file, change

“AllowOverride None”

by

“AllowOverride All”

Reply

Post a reply to this thread

Please log in with your Twitter account using the button below in order to participate.

Connect with Twitter