Notice: The Tweet Nest support forum has been moved to the GitHub issue tracker. Please report all issues there. Thank you!
Post a reply

/month.php & /favorites not found on server

A forum thread posted in Tweet Nest by djsteen on Mar 23rd, 2012

djsteen OP

Howdy!

I just setup Tweet Nest on my server, and I love it. Thank you!

I’m having trouble accessing /favorites (http://djsteen.com/tweetnest/favorites) and /[year]/[month] (http://djsteen.com/tweetnest/2012/03). Both result in a 404, and I can’t figure out why; both .php files exist on my server: http://cl.ly/2d3G2D372h3a322p351k

I couldn’t anyone with this same issue on the forums.

Thanks,
Derek

Reply

vA53

hey Derek!
I’ve got the same problem.
couldn´t fix it yet and there seems to be no help out there. :(

Reply

wfryer

And I’ve got the same problem on my new installation of Tweet Nest too:
http://twitter.wesfryer.com

Looking at the files in the directory with my FTP client, it appears the mainentance script which is importing the last 3200 tweets isn’t actually creating any files in my webserver’s directory:
http://twitter.wesfryer.com/maintenance/loadtweets.php

That’s why there are 404 errors: A directory for “2012” and the month “04” inside it have not been created at all:
http://twitter.wesfryer.com/2012/04

I’m wondering if this is a server permissions issue, where the script is not being allowed to create those directories and files?

Andy we need your help! :-)

Reply

wfryer

OK, I found this post and it looks like it might be the same .htaccess issue, b/c there are not actual directories being created by Tweet Nest:
http://pongsocket.com/forum/tweetnest/7

Haven’t found an answer yet tho…

Reply

wfryer

I experimented adding a .htaccess file into the directory where I installed Tweet Nest, copying the same one I had in the root of my Wordpress install, but that didn’t work.

Stuck for now.

Reply

graulund

As you seem to have discovered already, Tweet Nest doesn’t actually create folders in any way — the special URLs that look like a folder structure are put in place so the paths look more human readable.

This is what the .htaccess files help with in an Apache installation. Without them correctly installed, the server will actually try to look for that folder and, naturally, cry when it doesn’t find it. So this issue is usually due to these .htaccess files either being not present, not read or otherwise interfered with in some way.

The issue is complicated by the fact that the files are usually hidden on a UNIX-based system, so it can be hard to see if they are present. Then you need to make sure they are read and interpreted (see the “AllowOverride” directive in Apache config) and that the rules don’t clash with other similar files somehow (this is mostly trial and error).

I’ve heard that if you run Tweet Nest in a subdirectory of WordPress, the different .htaccess files for these two different apps collide in some way and create an issue. I haven’t been able to resolve this, though, because I don’t use WordPress myself. But it could be an idea to move it into a completely separate directory to see if that helps.

Reply

wfryer

Do you know what an .htaccess file needs to include so it will work properly? I successfully uploaded a file and renamed it with the ‘.’ prefix but I don’t think it included the requisite code. I used a generic version I found online. If you or anyone else can provide a sample file to use I’ll give that a try. I loaded Twitter Nest in a new directory as an ‘add on slot’ on my hosting account, rather than a subdirectory.

Reply

wfryer

OK, I got it working but I feel foolish! All I needed to do was rename the provided htaccess file you provided in the install files. Yikes! I guess I need to look at filenames more carefully. THANKS! Tweet Nest rocks. :-)

http://www.flickr.com/photos/wfryer/7064524651/

Reply

botaday

I had the same problem, I had to fix it by editing httpd.conf

In httpd.conf:

I changed this:
AllowOverride None

to this:
AllowOverride Options FileInfo

From info found here:

http://www.blackbeagle.com/web-hosting/apache-mod_rewrite-and-allowoverride/

Reply

Baltigo_Island

Hey there,

I solved the .htaccess problem in a different way. Maybe this post helps someone.
I added in the .htaccess file after “Rewrite Engine On”:

RewriteBase /

If you didnt install Tweetnest in your root directory you have to add the explicit folder

RewriteBase /folder1/perhapsfolder2

Only add this to the .htaccess-file in die main directory, not in the maintenance-directory.
greetings

Reply

Post a reply to this thread

Please log in with your Twitter account using the button below in order to participate.

Connect with Twitter