Notice: The Tweet Nest support forum has been moved to the GitHub issue tracker. Please report all issues there. Thank you!
Post a reply

“Could not connect to Twitter. Refresh the page or try again later.”

A forum thread posted in Tweet Nest by djchuang on Jul 3rd, 2013

djchuang OP

Thank you for updating Tweet Nest to 1.1 !! Much appreciated.. eager to get my past archive and current tweets up-to-date..

I’ve uploaded all the files from the new package, careful to avoid overwriting existing inc/config.php.

Tried entering my API keys on the authorize.php but getting this error message after I click <Authorize> — “Could not connect to Twitter. Refresh the page or try again later.” after repeated attempts during the past hour.

Might be more of a Twitter issue, will try again in a few hours and tomorrow, but just in case it might be something in my config or whatever, help appreciated if anything I should check.


djchuang OP

Found my problem (all by myself *grin*) - realized that I had to add the Callback URL (which needs to point to ./authorize.php) in the Twitter Developer’s settings <> and then the Tweet Nest <> Twitter API authorization went right thru!



Actually, (as far as I can understand, anyway) it is not important that the Callback URL points to anything specific on your Tweet Nest installation — a new one is always specified automatically when Tweet Nest contacts Twitter — only that it is set to *something* and not empty.

If it’s empty, the type of contact that Tweet Nest makes with Twitter is completely “turned off”.



I’m getting this same error. I’ve verified the key and secret are correct.
I’ve dumped the contents of the TwitterOAuth object and see them successfully transmitted but the response comes back with “401 Unauthorized”.
Anything I can try?



Every instance I’ve seen of this error has always been solved by making sure that the “Callback URL” field in your app on is not blank.

If it’s not blank in your case, and still does not work, then we have a more interesting issue.



I’m seeing this issue in a new install of Tweet Nest. My callback URL is set to the root of my tweet nest install, and I still get the error.

Any ideas what might be wrong?



Same Problem here.
Only to authorize into twitter on the setup.php file gives the error:

Whoops! An error occured that prevented you from being able to install Tweet Nest until it is fixed.

You must authorize Tweet Nest to use your Twitter account before continuing.

I’ll followed the exact installation steps.

Hits anyone?


Post a reply to this thread

Please log in with your Twitter account using the button below in order to participate.

Connect with Twitter